Harmony Central Forums
Announcement Announcement Module
Collapse
No announcement yet.

DL4 double preset mod problems

Page Title Module
Move Remove Collapse









X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • DL4 double preset mod problems

    I'm currently doing the switch/LED replacement, double preset and looper mods on my DL4.  Everything works fine with the exception of the double preset mod.  

    In double preset mode, if i change the delay time, the delay is a weird, warbly, digital interference sound.  It's basically the same sound you get when you're turning the delay time knob...but it never goes away.

    I've plugged in an expression pedal and it seems to do the same thing...however, for the expression pedal to work i have to have my double preset mod button turned on.

     

    Any ideas on what i did wrong?

     

    Here are a few pics (all white wires is the double preset switch, red wires is the looper mod switch) Switches are DPDT with LEDS.  Power and ground for the looper mod switch are coming from the double preset switch.

     

     

    Attached Files
    http://www.bookclubband.com

  • #2

    I haven't added the diode to the power side for the LEDs yet, but i wouldn't think that would cause this issue.

    http://www.bookclubband.com

    Comment


    • Faldoe
      Faldoe commented
      Editing a comment
      You need to have the ground wire on the expression jack tough both the ring and sleeve.

  • #3

    Something like this? (i would be adding the purple wire in this diagram)

    DL4.jpg

    Attached Files
    http://www.bookclubband.com

    Comment


  • #4
    Still no luck. I took the switch out completely and just put the 10k resistor between the tip and ground on the expression pedal jack solder points. (I also tried putting the ring to ground as well)

    Still the same warbly digital interference delays on certain delay settings...others work fine.

    Could there be an issue with the board?
    http://www.bookclubband.com

    Comment


    • grunge-rock
      grunge-rock commented
      Editing a comment

      They used to be


    • Shine-ei
      Shine-ei commented
      Editing a comment

      grunge-rock wrote:

      They used to be


      good call on changing that, I remember I broke a DL4 back when they were expensive and the bees knees.

       

      Sorry for providing absolutely no use or help to your problem!


    • Faldoe
      Faldoe commented
      Editing a comment

      grunge-rock wrote:

      That didn't work either.


      if you didn't do the mod like that in the link I posted I don't know what else to tell you other than you might be a tard.

      Any more pictures of the mod after you changed them?

      Picture of the replacement footswitches and their wiring. 

      Does the DL-4 work fine when the double-preset mod is disconnected?

      Also; are you sure the footswitch you're using is a latching and not a momentary switch?


  • #5
    Yes. The dl4 works fine when the mod is disconnected.

    Classy. Not a tard, built/modded plenty of pedals with no issues.

    Switch is latching, as is the looper mod switch, which works fine.

    All I'm doing now is a 10k resistor directly between the tip and ground solder points of the exp. jack.
    http://www.bookclubband.com

    Comment


    • Faldoe
      Faldoe commented
      Editing a comment

      grunge-rock wrote:
      Yes. The dl4 works fine when the mod is disconnected.

      Classy. Not a tard, built/modded plenty of pedals with no issues.

      Switch is latching, as is the looper mod switch, which works fine.

      All I'm doing now is a 10k resistor directly between the tip and ground solder points of the exp. jack.

      did you lift the tabs on the expression jack. - When you insert an external expression pedal, the tabs on the jack are lifted by the inserted expression pedal. Since you're not using on, you have to physically bend up the tabs to simulate the plug.

      If you have a DMM, I think right now you'll get a reading that the tip is shorting to ground. Once you lift those tabs on the jack, it should read open. The mod should work then.



Working...
X