Jump to content

bass with no sound.. help??


xdamagexx

Recommended Posts

  • Members

i need suggestions about repairing my bass

i purchased a Schecter Ab-1 on ebay last year.. i love the body and it was awsome when i got it. but a couple months ago it just stop working.. so i looked her over and nothing was outta the ordainary. i called up schecter and they were very helpful i thought i might of been the 1/4 jack. so they sent me some free ones to try,., which i did and it didn;t help. so i ended up taking the bass to my local guitar store. and the dude that works on them looked it over for a day then called said he had no idea what it was.. he said he would call around and figure something out and let me know whats up. that was 3 weeks ago and no word.. i called Schecter and they said that model discontinued 5 years ago and i would have to replace all electronic and pickups. he told me to call EMG. so i did and they said i would have to replace it all and they had the solution for like $240. thats just the pickups and preamps. no installution but i figure i can install it easy enough and not have to go through the slow local guuuitarr dude. i understand replacing the preamp. but why the pickups? they are EMG HZ. can they go bad? everything at once? does anyone have anyother fixing suggestions? thanx m/

Link to comment
Share on other sites

  • Members

 

Originally posted by xdamagexx

i need suggestions about repairing my bass

i purchased a Schecter Ab-1 on ebay last year.. i love the body and it was awsome when i got it. but a couple months ago it just stop working.. so i looked her over and nothing was outta the ordainary. i called up schecter and they were very helpful i thought i might of been the 1/4 jack. so they sent me some free ones to try,., which i did and it didn;t help. so i ended up taking the bass to my local guitar store. and the dude that works on them looked it over for a day then called said he had no idea what it was.. he said he would call around and figure something out and let me know whats up. that was 3 weeks ago and no word.. i called Schecter and they said that model discontinued 5 years ago and i would have to replace all electronic and pickups. he told me to call EMG. so i did and they said i would have to replace it all and they had the solution for like $240. thats just the pickups and preamps. no installution but i figure i can install it easy enough and not have to go through the slow local guuuitarr dude. i understand replacing the preamp. but why the pickups? they are EMG HZ. can they go bad? everything at once? does anyone have anyother fixing suggestions? thanx m/

 

 

hey, this isn't bass related, but weren't you the guy who was just in a bad car accident? how are you feeling?

Link to comment
Share on other sites

  • Members

Originally posted by themusicdude



hey, this isn't bass related, but weren't you the guy who was just in a bad car accident? how are you feeling?

 

what????

:rolleyes:

im asking about how to fix my bass? is that not proper for this forum?

 

did the wreck mess my head up that much?

 

and yes i was in a bad wreck last week.. im sore and tomorrow getting my staples outa my head hopefully.. all 42. but im a gettin betta.. thanx

 

m/

Link to comment
Share on other sites

  • Members

Originally posted by xdamagexx



what????

:rolleyes:
im asking about how to fix my bass? is that not proper for this forum?


did the wreck mess my head up that much?


and yes i was in a bad wreck last week.. im sore and tomorrow getting my staples outa my head hopefully.. all 42. but im a gettin betta.. thanx


m/

 

no, i meant my POST wasn't bass related.

 

good luck on the recovery.

 

:)

 

-am

Link to comment
Share on other sites

  • Members

...Have you replaced the battery?

 

Just checkin, ya know.

 

HZs are passive pickups, if I remember correct. So the chances of them both frying at once is pretty much nil.

 

Now, the preamp would be where I'd focus attention. Pull that puppy completely out of the cavity and make sure all the resistors and components are in the correct places and connected.

 

If they all are, its probably a fried component. You can figure out which one, but it may take a while. It may be easier to just wire your bass into passive mode at least for now.

Link to comment
Share on other sites

  • Members

well its at a guitar store and the dude has had it for a month and no calls or nuthing.. he told me that he couldn't wire it passive.. i ain;t that smart but EMG HZ are passive so that blew my mind.. but i know that at least.. i figured i could wire it passive but when he said that i was like ohhh..

 

and i did replaced the battery... that was the first thing i checked thank u very much... lol im from arkansas so im kinda slow but not that slow.. lol.. :rolleyes:

 

i talked to EMG and they said i would have to replace it all.. they said the preamp is Schecters so they have no idea about it.. but to replace what i got their suggestions were for 2 EMG35DC pickups that come with preamps. but damn its like 200 for them both. and thats not installed.. which would make it all active and probley sound killer. but heck im cheap.. if i did that i would have about as much in the electronics as i paid for the bass on ebay.. lol so im lost.. i have wrote EMG a few more questions.. so hopefully i find something out tomorrow.. but why should i have to replace the EMG HZ.? has anyone ever heard of them or even both pickups farting out at once...???? i mean its a post with wires wrapped around it. what could go wrong.. it worked fine one day and the next nuttin...

 

m/

Link to comment
Share on other sites

  • Members

I bought a schecter last february. I love it. I bought it brand new and after about 2 months the same thing happened to mine. Mine did come stock with active duncan designed pups and an active duncan designed preamp. I tried everything. I checked the battery, I tried a different amp, I wiggled wires, tried a different cable, nothing worked. I was pretty pissed. Then one day it just started working again.

 

So, instead of having some great solution to your problem, I'll just tell you a story.

 

Once upon a time in a galaxy far, far, away....

 

oh, nevermind.:rolleyes:

Link to comment
Share on other sites

  • Members

Sunburst is on the right track!

 

Don't let anybody BS you with having to replace everything. THat's a ridiculous proposition that will only make more money for the person giving such advice.

 

Go to Radio Shack (or an auto parts store) and get a package of jumper wires. Clip two of these to the output jack. Clip the other end to where the pickup wires come to the preamp board. Plug the guitar into an amp and tap on the pickup(s). If the tapping comes through the amp, it's NOT the pickups.

 

{Note: if there isn't enough exposed wire to clip to, stick a pin into each wire and clip to the pins. Just make sure the pins aren't touching each other, or anything else.}

 

You can trace the signal further from that point.

 

There is a 99.9% probability that a very inexpensive part on the preamp board has failed. Find it. Replace it. Problem solved.

Link to comment
Share on other sites

  • CMS Author

There's a few possibles, and even fewer probables:

 

1. Wires from battery are broken, so preamp gets no power. Decent probability, but sudden failure isn't so likely...usually a wire will be intermittent first before it finally breaks off.

 

2. Both pickups have failed (simultaneously). Fat chance.

 

3. Preamp has failed. Decent probability.

 

4. The battery you used to test with is also dead. Don't laugh; it's happened to me more than once.

 

The most probable is #3. So eliminate the rest by careful troubleshooting, and look into getting a new preamp. You don't need to replace pickups. An Aguilar OBP-1 is $99 at Musicians Friend. If you know how to solder, installation is easy. If you don't, it should be an hour labor to install. It's only about a dozen easy solder connections.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...