Jump to content

Active Battery Issues


Recommended Posts

  • Members

Guys, why are the 4 AA batteries not powering up my GFS Redwire active pickups? When I bought this guitar, they had two double A batteries going, but said I could add 2 more for the volt mod.

 

So here I am with 6 volts going and there's nothing but silence.

Link to comment
Share on other sites

  • Members

Stupid question: Did you install the batteries properly?

Check the wiring, sometimes the ends from the battery box break.

Check the battery wire/ground wire at the output jack. If one's not making contact, dead silence.

  • Thanks 1
Link to comment
Share on other sites

  • Members
On 6/27/2021 at 7:50 PM, Mr.Grumpy said:

Did you confirm this with a volt meter? Is your polarity correct? 

 

Well, my pickups were a little hot, so I used my trusty demagnetizer on them to reduce battery usage.  Now here I am with 4 AA batteries that aren't cutting it.  I should try newer batteries and see what happens.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...