Jump to content
Sign in to follow this  
isaac42

Repaired a couple of amps today.

Recommended Posts

I got lucky with the first one. Power switch wasn't working. Fortunately, it was stuck in the ON position, but the guitarist wanted a finctional switch. I opened it up and tried to get the switch to move. No good. No local place to get the correct replacement, so I laid out the options for him: leave it as is, or I could drill a hole and put in a difference switch. He chose the latter.

So, I proceeded to break it down. I took out the circuit board to give me room to drill, and, waddaya know? The switch worked. No idea what was hanging it up before. So I cleaned off the old, dried up heat sink compound, added some new, and put it all back together. Tested it out, and everything works.

Then I went to work on my own amp. Bad buzz, intermittent. Also, a rattle when I shook the cabinet. I assumed that they were connected, and they were. There was a screw loose that had come to rest against the speaker cone. Had to break it down a lot further than I would have thought to get the screw, but I did get it, and got it back together, too. All good.

Nice to get something accomplished.

  • Like 2

Share this post


Link to post
Share on other sites

"I took it  apart and put it back together and it worked again." That's my kind of repair, fix 'em without knowing how or what was wrong. It's results that matter. ;)

  • Like 1

Share this post


Link to post
Share on other sites
On 10/26/2019 at 3:17 PM, DeepEnd said:

"I took it  apart and put it back together and it worked again." That's my kind of repair, fix 'em without knowing how or what was wrong. It's results that matter. ;)

That seems to be my MO these days.

Share this post


Link to post
Share on other sites
1 hour ago, isaac42 said:

That seems to be my MO these days.

The amp is working properly again, right? Therefore you fixed it. Take the win. A couple of years ago, I told our niece, "You know, you're my favorite niece." She protested, "I'm your only niece!" My sister-in-law, God bless her, told her, "Shut up and take the compliment."

  • Haha 1

Share this post


Link to post
Share on other sites
On 10/28/2019 at 3:07 PM, DeepEnd said:

The amp is working properly again, right? Therefore you fixed it. Take the win. A couple of years ago, I told our niece, "You know, you're my favorite niece." She protested, "I'm your only niece!" My sister-in-law, God bless her, told her, "Shut up and take the compliment."

Oh, yeah, I'll take it. I'm not complaining. I do kinda wish I knew why the switch was jammed, and how it came loose, but I may never run into this again, so no worries.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...