Jump to content
Sign in to follow this  
ksl

BOSS TF-2 Dynamic Filter Issue??

Recommended Posts

Posted (edited)

Hi all~~ I just purchased this pedal used, & while it powers up fine using a 9v battery, it won't do so using my 9v Mutron Battery Buddy. All I get is a very very faint light, visible only with the room pitch black. I also have another mid 80's BOSS HF-2 with the same requirements & plug input, and that one works just fine, as do my other 4 pedals in the chain. Seller claims "although it is the pedal of this age, ACA Series or 12V is required when using a DC plug.

There is also a method to use it connected to the BOSS power supply(PSM or LS or TU).​​​​​​"

 

12v?? I've never heard of that before from a 9v Boss device.

Am I missing something?

Thanks, kenny

🕉 [TABLE=align: center, border: 0, cellpadding: 0, cellspacing: 0]

[TR]

[TD] [/TD]

[/TR]

[TR]

[TD] [/TD]

[/TR]

[/TABLE]

 

Edited by ksl

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...