Jump to content
Sign in to follow this  
Ikthus

Has anyone else tried to register at the new SSS?

Recommended Posts

I don't mean log in. I mean register from scratch. It would appear to be impossible.

Share this post


Link to post
Share on other sites

I don't think new people will be able register until the terms of service are up, so people can agree to them. But I'll check...

Share this post


Link to post
Share on other sites

Just heard back...it's being fixed. The problem was indeed TOS-related.

Share this post


Link to post
Share on other sites
I don't mean log in. I mean register from scratch. It would appear to be impossible.

 

Things are still a little rocky over there. I tried to register and it told me my user name was already in use. OK, so I recalled that I used to be registered on a previous version of that forum, so I tried logging in with my "already used" name and every password that I might have used and nothing worked. When I tried using the "password reset" that was supposed to send me an e-mail with a temporary password, it took several hours for the e-mail to arrive and even though I tried using it within the 24 hours that it was supposed to be valid, I got the "wrong password" response. After several rounds of this, I finally one that worked and I was able to log in.

 

In the meantime, I used the Contact form and explained the problem, and got a next-day reply from Jim Quinn, the administrator, who offered to manually change my password and said he'd look into the problem.

 

Craig's explanation is plausible, but it's certainly the wrong error message for the problem. If it responded to "Please check the box that you agree with the terms of service" then I would have asked "Hey! Where's that?"

 

I trust it will get sorted out soon. See you there.

Share this post


Link to post
Share on other sites

It's fixed now, 50 people have registered without problems today. Good to go!

Share this post


Link to post
Share on other sites
It's fixed now' date=' 50 people have registered without problems today. Good to go![/quote']

 

Still not working for me :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...