Jump to content

Can't record audio into Windows 8.1 - it's driving me crazy. Can anyone help he figure out what I'm doing wrong?


Recommended Posts

  • Members

I'm trying to retire my old WinXP computer. I've been using it to record things in either Audacity or Power Tracks Pro Audio through an Edirol UA-1A audio to USB interface.

 

I have 3 Edirol UA-1A and one Ediirol UA-20 USB to Audio interfaces. They all work fine on my XP computers using the standard Windows Audio drivers.

 

I need to figure out how to record on the Windows 8.1 computers before retiring the XP, and that's where the problem arises.

 

I plugged the UA-1A into the Win8.1 computer, it recognizes it and loads the standard Windows audio driver.

 

I connect the output of the mixer to the UA-1A audio input, and select the UA1A in Audacity. I select the Edirol as the input in the Devices dialog, and start recording. No signal, nothing, nada, zip, zilch appears in Audacity.

 

I make sure the UA-1A is not disabled and checked green in the Windows Device Manager.

 

I try the same thing using Power Tracks Pro Audio DAW and I still can't see anything on the VU meters.

 

OK so I think something must be defective, so I try all 3 (known good) UA-1As, different audio cables and even a second Windows 8.1 computer.

 

To omit possible conflicts, I played the sequence I'm recording in one computer (USB-Midi into a synth rack with mixer) and taken the output of the mixer and tried to record on the second computer, only opening the required programs.

 

I even tried shouting great obscenities, and that didn't work ;)

 

I'm at a loss.

 

Can you think of anything that I'm missing?

 

Thanks!

 

Bob

Link to comment
Share on other sites

  • Members

Thanks all for responding.

 

OK, I got a brand new M-Audio M-Track interface with Win8 drivers.

  1. I download the drivers from M-Audio's website for 64bit Win8,
  2. Install them per the directions (I even read the manual first - don't tell anyone) smiley-wink.png' alt='16x16_smiley-wink.png.ac1518ec0dabe458f31c1303ed9ec588.png' alt='smiley-wink'>.png'>
  3. Hook my mixer's output to the M-Track's input
  4. Connect the USB directly to the computer (not in a USB hub)
  5. Open Audacity go to Edit->Preferences->Devices->Recording Devices:-> and chose the M-Audio
  6. Start playing the audio through my mixer
  7. Adjust the levels on the M-Track so the LED VU meters are occasionally hitting yellow - thus verifying that I have input signal
  8. Hit "Record" on Audacity, and get (a) no LED VU activity (b) nothing recorded - nada - zip - zilch - not even any noise.

I tried it on a second Win8 computer - same results. I was even sure to play the MIDI sequence I used to feed the synths in the mixer on a different computer from the one I was trying to record on - to avoid any unknown conflicts.

 

So I spend $100 on a new interface to eliminate that problem. Now I have 9 USB-Audio interfaces. I guess you can't have too many.

 

I'm really flummoxed. I've been doing this since the beginning of XP and perhaps on Win98 pretty much the same way and never had a problem.

 

Phil and Bieke, you mentioned ASIO4ALL, do you still think this might do something the new interface didn't?

 

Any more ideas. I've run out of great obscenities to shout. I'll need to go to Google and convert them into Japanese.

 

Thanks,

Bob

 

PS: I made sure the M-Audio drivers were active in the Windows Device Manager

Edited by Notes_Norton
PS
Link to comment
Share on other sites

  • Members

The problem is solved! - and boy do I feel stupid. It was "pilot error" all the time.

 

A long time ago, I was using an app that amplified my typing noises via the internal mic through the external amplified speakers. It was so long ago, that I don't even remember which program it was that did that.

 

ThinkPad has a function key to turn off the internal mic. Fn+F4. When it does, a little orange LED lights up. The computer remembers this setting until I press Fn+F4 again.

 

!keys.jpg

 

As you can see, this is a microphone icon, and it did the job of turning the internal mic off.

 

Great ideas come in the 3 B's - the bed, the bath, and the bus. This one came in the bed. I only got about 4 hours of sleep last night so I took a little 45 minute "power nap" after lunch. I woke and wondered if this turned off just the mic or all the audio.

 

The icon looks like a microphone, so I had no reason to suspect that it would turn anything but the mic off, but I've been grasping for straws for days before I even posted the first message here. So I tried it.

 

IT WORKS!!! Even my old UA-1A interfaces work with the generic Windows drivers!!!!!!!!! The elation of finally fixing the problem has more than overwhelmed the embarrassment of feeling so stupid that I didn't try that first.

 

Thanks for your responses.

 

Insights, incites, and sighs of relief by Notes

  • Like 1
Link to comment
Share on other sites

  • Members

I had issues switching from XP to Win 7 as well. It seems they put the windows mixer in control of audio options. When I installed the OS it picked up my on board windows sound card first. Then when I installed my M-Audio 1010LT cards it didn't play back through all the various media players. I had to right click on the windows mixer and select my sound cards under the mixer options.

 

When I ran XP, the driver set up its own independent mixer console that wasn't dominated by win 7. It was more like a parallel installation. In win 7 the win mixer seems to be in series with the M-Audio's mixer. You have to have the windows mixer set for all the M-Audio ins and outs for all your playback/recording software pass the audio.

 

I can adjust master overall volume from either the DAW, Media player, the M-Audio mixer or the Windows mixer. If I bring the master volume down on the Win mixer, it isn't linked to the M-Audio mixer so I have to check both when adjusting my output levels (which are normally max with my cards.

 

I suspect your internal mic is linked to the on board windows sound card. If you don't use it, disabling the on board sound card might be the way to go. I've found Win 7 occasionally defaults things back to the original install settings occasionally. I suspect this occurs when updates have been done (Windows does updates every Wednesday) It a real pain in the butt too because I run several different audio programs editors etc and they seem to default back to the wrong audio settings so I have to go in there and figure out which ones they are.

 

Link to comment
Share on other sites

  • Members
Glad to hear that you got the problem solved Notes - I don't think I would have ever thought of suggesting checking the keyboard!

Thanks.

 

I batted my head against the wall for weeks before thinking of it myself. This thing occupied my brain for most of my waking hours, day after day, week after week, and it's good to have it out of my head.

 

This is my first computer with those little additional F functions that lock. My Win7 Think Pad needs an alt key with the F and the Fn which is a bit of a PITA.

 

I had a feeling it would be something simple and stupid, but I didn't know how simple and stupid.

 

I've been recording audio at least since W98 and perhaps W95 and never had a problem setting it up to work. Just the usual, learn how to use the software, how high to drive inputs without distorting, and things like that.

 

I'm glad I figured it out, as the Win 8 computer is soooooo much faster than my old IBM ThinkPad. Lenovo purchased ThinkPad from IBM in 2005, so this computer is older than that, with some very old processing power. ThinkPads are built like tanks. I still have a 2002 that jumps around on stage with me on a keyboard stand. It plays the mp3 backing tracks that I make myself so the old technology doesn't matter at all.

 

Now I'll strip all the unnecessary software from the IBM so it can become another spare for my stage setup.

 

I'm happy again.

 

Notes

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...