Jump to content

Faint, crackly kind of noise coming out of one PEAVEY PR15


Recommended Posts

  • Members

First off, sorry for not knowing much of the terms associated with speakers. I have a lot to learn.

So I recently purchased a QSC GX5 amp for my PEAVEY PR15 speakers that I had bought a few years ago. Now, I bought these speakers from a garage sale and they were working fine back then. But I had them in my garage since because I didn't have an amp to power them until now. So I plugged everything in, the amp works fine and one of the speakers works fine too. But one of them didn't have sound. So I opened the back plate to see if there was anything out of place. Turns out that it does have sound, but the sound is coming from the "motherboard" where the fuse or lightbulb is located. At first, it sounds like static/crackly kind of noise. But if I turn up the volume from my amp or my ipod, you can hear that it's playing the music but only on the "motherboard". For some reason it's not playing through the actual speakers.

Can anyone tell me what's going on and maybe there's a way I can fix it? Thanks!

Link to comment
Share on other sites

  • Members

Actually, if there is a short, or in some instances an open circuit, the inductors can make noise due to the electromagnetic forces on the wires which move (I'm sure these are cehap non-potted or varnished). 

Before you damage your amp, I would take the speaker to a quality pro audio repair shop and have them take care of it. Troubleshooting these kinds of problems takes some tools and experience. You do not want to destroy your amp (yes, a possible outcome), because you do not know what may have been done to this speaker. 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...