Jump to content

ehx poly chorus noize


stereotypy

Recommended Posts

  • Members

to the ehx polychorus owners out there:

 

i own it too.. :thu:

 

:confused: but have some trouble with it. when i dial in the 12string sound (double track, and delay full) than there is a high-pitched noize which is ugly and annoying.

 

is this normal or broken? btw/ it's not only the double track setting it's always when i dial in the delay from 3o'clock and past. but i would like to use the 12 string settings cause it sounds awesome but ugly with that noize.

 

flo.

Link to comment
Share on other sites

  • Members

don't remember who it was but i saw a pedalboard with the pc set like that (12 string) on this forum... for i am fanatic i saved the pic (not the name, what a shame..:rolleyes: )...

maybe YOU recognize it.. :wave:

 

anyway.. than i think i'll have a look into the pc for the trimpot...

 

here's the pic:

 

11e.jpg

Link to comment
Share on other sites

  • Members

i fixed it!!! :thu:

 

thanks guys for the help! i would have sent the poly outta mi board, but know its a keeper.

 

i took off the rear-plate and looked at the trim-pots. well, there were 8 i think. so i looked for the trim next to the delay and just tried a little fixing. got a little btter, and little worse.. put it back in the "normal" position..

 

well, actually it was the 8th trimpot i tried which solved that problem!! the last one on the top of all... could have gone faster but now it's fixed anyway..

 

thanks guys1

:wave:

Link to comment
Share on other sites

  • Members

yeh ive noticed a slight high pitched metallic-ness to the PC... but it has never annoyed me enough to want to open it up and {censored} with it...

the polychorus is such an awesome pedal, its was one of the first effects i bought, and its still on my board...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...