Jump to content

Anyone using a BYOC Triboost?


Recommended Posts

  • Members

Ive just ordered myself one and was intending to use the linear (i think) section at the end of my chain as an always on buffer and to give the signal a slight boost to give my amp a touch of extra sparkle. Has anyone tried it this way? I know you can use it at the front of the chain to slam another overdrive for lead work too.

 

I am also considering buying a reverb pedal such as a Holy Grail to wet the tone of my none-reverb / no effects loop amp and the original plan was to sit it on top of the amp and have it always on. Will the triboost be too much push for the HG?

 

Cheers

Link to comment
Share on other sites

  • Members

 

i have a build triboost that doesn't work

i guess that doesn't help you

if i get it working i'll let you know

 

 

what's wrong with it (I know that's a hard question to answer, so in your best words)?

Link to comment
Share on other sites

  • Members

I had one for a while, great little pedal. I just wasn't using it much so I got rid of it. The LPB mode sounded evil and huge into my old JCM800, and the full range germanium was great with a cranked fender amp.

 

:wave:

Link to comment
Share on other sites

  • Members

 

what's wrong with it (I know that's a hard question to answer, so in your best words)?

 

 

it lights up and when i turn the rotary switch i can hear it click through the amp

but no sound comes out. bypassed or engaged

i posted some pics on the BYOC forum but everyone says my switch is wired wrong. it's wired exactly the way it says in the directions and the way they tell me to do it

it's extremely frustrating

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...