Jump to content

Philosophers Tone Problems - Loud Click In..Normal?


Recommended Posts

  • Members

Just picked up a Philosophers Tone and its got a very loud CLICK coming out of the amp when engaged. Is this normal? I'm assuming it is, but I cant imagine why.

 

I got it first in the chain, just before a SD9M, then bypass looper, and into the amp, on the supplied power supply.

 

Actually wasnt too impressed honestly, theres some sweetness in there, but very little for $180.

 

Anyone else ditch the bitch for something better?

Link to comment
Share on other sites

  • Members

 

Another loveless marriage with the PT, haha. I use mine for what you're looking for. Here's what works for me:

Grit - off

Sustain - 3:00

Blend - 10:00

Treble - 1:00

Volume - 2:00

See if that helps yer chub.

 

 

dude like 7/10 people hate this pedal. we are the only ones who know how sexy it really is.

Link to comment
Share on other sites

  • Members

...try a mercury-damped switch for the tb?.....oh wait, can't get them any more.

 

...maybe a good spray with a freon-based contact cleaner will do the trick? .....ooops, sorry, ozone layer, my bad....

 

...could be the silver solder corroding, maybe try some good oldfashioned 60-40?

 

 

 

Sorry, I'm all out of ideas.

Link to comment
Share on other sites

  • Members

 

Another loveless marriage with the PT, haha. I use mine for what you're looking for. Here's what works for me:

Grit - off

Sustain - 3:00

Blend - 10:00

Treble - 1:00

Volume - 2:00

See if that helps yer chub.

 

 

Thanks I'll check it out, I got it on "clean sustain" factory settings right now.

 

I'll tell ya, a guy can get used to the unlimited sustain when mixed with some dirt and reverb...haha.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...