Jump to content

Roland JC-120 question


ablei

Recommended Posts

  • Members

Hello, my Roland JC-120 was with a friend for the past year or so. Anyway,I recently got it back, I turned it on, and there is quite a bit of hiss coming out of it. I can't remember if when the JC-120 turns on if it's totally silent or if there was a little hiss. What could this be due to? He told me, that the amp was played at a very very loud volume, and I'm thinking this might have scrwed up the speakers--and that the hissing is because the speakers are blown or something to that effect. Who should I take this to get looked at? any idea of what price range we're talking about when fixing this problem?

thanks much

Link to comment
Share on other sites

  • Members

Though I think it's possible both speakers may've been messed up at the same time, I think it's unlikely. You could try taking the attached wires off one speaker and see if the other one has the sound, then you could do the other speaker. If they both sound the same, then maybe you could plug in an extension speaker to a jack on the back of the amp. If an extenstion speaker also sounds the same, then something's going on w/ the amp itself.

 

You could always check settings to see if they're set a lot differently than what you normally used. If the bright switches are turned on or the treble/presense too high, that could be a problem, as well. Hope it goes okay for you. I just got rid of one at a local pawn and could get it out for fairly cheap but think I want to go back to a fender-type warmer clean channel for what I'm going for more musically now. I love the Rolands, though. :)

Link to comment
Share on other sites

  • Members

My jc 120 has an annoying hiss since the day I bought it new. Other jc owners say the same thing (the newer jc 120s anyways)

Make sure your amp is not near a tv, computer or anything electronical when playing because that just loudens the hiss and also puts a green blur on the tv screen, even when the amp is not on. My friend almost went out and bought a new tv set, lol because my amp was sitting next to it all week and he didn't realize what it was.

Link to comment
Share on other sites

  • Members

 

Originally posted by 72 bonne

a green blur on the tv screen, even when the amp is not on. My friend almost went out and bought a new tv set, lol because my amp was sitting next to it all week and he didn't realize what it was.

 

 

Did the TV sit on the ground with the amp right next to it?I think the only thing that would cause that would be if the speaker's magnet was too close. Any speaker would cause that ... it'd have to be pretty damn close,though.

Link to comment
Share on other sites

  • Members

Mine hisses too. I think its in the amp itself. Tried plugging it into my power conditioner and it still hissed. When I play it loud, i don't notice it too much, but it still bugs me. Let me know if you find out how to fix it.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...