Announcement
Collapse
No announcement yet.

Focusrite Pro 40 popping and clipping

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Focusrite Pro 40 popping and clipping

    CAN ANYONE POINT ME IN A DIRECTION TO SOLVE AUDIO CLIPPING USING MAC 10.5.8 AND FOCUSRITE PRO40? The problem started when I switched from a MOTU audio interface to Focusrite.

  • #2
    is it from audio clipping or is it being caused by the latency set too low. Daws use buffers to store data as it flows in. This allows the bits to stack much like a gas tank in a car. If the tank is too small and the COU goes to grab data that isn't there it will stick zero bits in the stream. Its like an engine sucking air and the engine misfires. The gas isn't feeding into the tank as fast as the engine is sucking it out.

    By increasing the buffer, and/or latency settings you virtually make that gas tank bigger and less likely to run dry. USB is a master slave port that can be throttled by the CPU depending on how hard the CPU is working. If the data stream filling the tank gets disrupted during intense CPU demand and the USB port gets throttled, the tank will still have a enough reserve and not run dry.

    I know allot of the older MOTU stuff used a PCI card. PCI and Firewire are peer to peer communication ports and run in the background steady and aren't affected by CPU demands like USB ports are. MOTU has been making USB stuff now too. Most of your higher end computers will handle USB quite well but even there you can have very fast and very slow 2.0 ports. Its mainly a computer architecture issue and what those USB ports are shared with, They connect to the mother board using IRQ's If the USB is connected on an IRQ 15 or below its an actual IRQ and usually does better then a Virtual which is 16 or above. You can also have them shared with a high consumption device like a Network board and when the computer is connected, the audio interface has to share that port and gets throttled down to where it studders.


    There are many other possibilities too. It may be anything from a hard drive speed issue, driver issue, optimization issue or just a gear compatibility issue. I can only guess with the limited post info. so I stick with the most common.

    I'm not a mac guy so I'm not real familiar with the Mack codecs. I know windows will use ASIO or WDM drivers. These are the fastest protocols for moving data in a pc too and from the Interface to the hard drive. Macs use a different protocol so you'll need to look in the manual and check the driver setup and make sure you have the latest drivers for your particular operating system. Be sure the interface is compatible with your computer specs.

    If the pops are from overdriving then that's just a simple matter of turning the input gain down and turning your headphone/monitors up. So long as the input gain levels are below 0db on your DAW meters you should be OK.

    Some interfaces use a 10db pad for adjusting your levels to your monitors so if they are low and you're having to crank up your inputs to where you're hearing them, then look for a pad switch. It may be in a software driver setting. Play back some commercial music on your computer through the interface. You should hear the monitors at a decent volume. Then when you feed the interface recording if you match the mic or instrument to the same level as the recording play back, the gain levels you're feeding the daw along with its track meters should be in the safe range.

    Buffers and latency are set either through your daw program audio settings menu or through the interface driver setting. You should have downloaded and installed manufacturer drivers when you set up the Focusrite. The stock settings are a starting point. If you're running allot of plugins with high CPU consumption you may have to increase both latency and buffers to compensate. Adjust them up until the popping goes away. Computers need time to crunch the data. If you try and push their brans too hard and not leave them enough time to crunch those numbers they suck air and give you allot of noise. When you're just on the edge it may be an occasional pop or click. If you're too short you crash.

    Comment


    • #3
      Originally posted by WRGKMC View Post
      I'm not a mac guy so I'm not real familiar with the Mack codecs. I know windows will use ASIO or WDM drivers. These are the fastest protocols for moving data in a pc too and from the Interface to the hard drive. Macs use a different protocol so you'll need to look in the manual and check the driver setup and make sure you have the latest drivers for your particular operating system. Be sure the interface is compatible with your computer specs.
      Macs don't require drivers. The built in Core Audio API takes care of the interface - it really is "plug and play."

      Every worm, every insect, every animal is working
      for the ecological wellbeing of the planet.

      Only we humans, who claim to be the most intelligent
      species here, are not doing that. ~Sadhguru

      Comment


      • #4
        You could be having resource issues with your Mac. Run the Activity Monitor app which is located in the Utilities sub folder of the Applications folder and make sure you are not maxing out your RAM.

        If you are running your browser at the same time you may not have enough available RAM which will cause the system to start swapping the contents of the memory out to the hard drive. Spotlight (or Sherlock) is an indexing program that runs in the background to speed up searches on the hard drive and it should be turned off in Preferences.

        Here is a link to a list of instructions on optimizing your Mac for audio.

        http://us.focusrite.com/answerbase/o...-mac-for-audio
        Every worm, every insect, every animal is working
        for the ecological wellbeing of the planet.

        Only we humans, who claim to be the most intelligent
        species here, are not doing that. ~Sadhguru

        Comment


        • #5
          I would also recommend NOT running the Saffire MixControl app at the same time as your DAW.

          btw, what model Mac are you using and how much RAM do you have? What app are you using to record with?
          Every worm, every insect, every animal is working
          for the ecological wellbeing of the planet.

          Only we humans, who claim to be the most intelligent
          species here, are not doing that. ~Sadhguru

          Comment


          • #6
            Thank you all for the responses and help. My system:
            Power Mac G5
            2.2 GHz
            Dual core
            512 KB cache per cpu
            4.5 GB mem
            1GHz bus speed
            Focusrite Pro 40 firewire audio interface
            DP 7.2.4

            iTunes is also causing the popping, as well. I am looking into the rest of your suggestions.

            Comment


            • #7
              As WRGKMC has suggested, try increasing the buffer size in DP. It seems like you should have enough RAM if you are not running other apps in the background.
              Every worm, every insect, every animal is working
              for the ecological wellbeing of the planet.

              Only we humans, who claim to be the most intelligent
              species here, are not doing that. ~Sadhguru

              Comment


              • #8
                Originally posted by baremic View Post

                iTunes is also causing the popping, as well. I am looking into the rest of your suggestions.
                Are you running the Saffire MixControl when you get the problems?

                ​Have you by any chance setup an Aggregate Device (in Audio MIDI Setup) on your Mac?
                Every worm, every insect, every animal is working
                for the ecological wellbeing of the planet.

                Only we humans, who claim to be the most intelligent
                species here, are not doing that. ~Sadhguru

                Comment


                • #9
                  No I am not running Saffire MixControl and I'm not combining audio devices in the Audio MIDI setup.
                  I am reading more about adjusting the the buffers.

                  Comment

                  Working...
                  X