Harmony Central Forums
Announcement Announcement Module
Collapse

Announcement

Harmony Central has “soft launched” our new mobile experience this past week. While we have done extensive testing, we know that with a community as large as HC that there will be items that surface that will still need to be addressed. We are asking that you utilize the thread belowto report any challenges you may encounter. Here are the things we request you provide: A brief description of the issue, the device and operating system version you were using, the browser and version, screen resolution, and a screen shot of the display.
Thanks for your patience as we work towards the best experience we can provide to our community.

http://www.harmonycentral.com/forum/...ablet-feedback
See more
See less

Crest Powered PA Speakers - One drops partially out

Page Title Module
Move Remove Collapse









X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Crest Powered PA Speakers - One drops partially out

    Good Evening -

    Posting here because I think this situation best matches recording rather than live sound...  not sure.


    I have been using a pair of Crest 15" Powered Speakers for 6 years in my studio.  They have only been out of the house 4-5 times.  My acoustic group rehearses by running everything into a MOTU interface then into a MacPro (GB) and then out thru a Mackie mixer to the speakers.  The connections rarely get touched - we just leave everything connected.

    Over the 6 years, 2-3 times ONE of the speakers seems to partially lose its connection.  The 15 speaker drops out but we still have the horn.  It's only ONE of the speakers and it's the SAME speaker each time.  In the past the situation has eventually corrected itself.  One time I had called the folks at Peavey and was about ready to pack up this beast and send it to them for a look-see when it came back to life.

    It has happened again.  Any thoughts on what I should do to get this piece back on track?

     

    Thanks,

    Russell


  • #2

    Electrical connections are just the pressure of two contacts together. They are not soldered to a perminant joint so they are exposed to the air. This means dust and oxidation can get in the contacts making for a faulty connection.

    In a speaker cab you often have press on connections that can loosen from vibration. You can also have solder connections to the speakers and crossover circuit boards with solderd components vibrate loose from their connections especially if those connections werent wave soldered well.

    I had one of my monitors start doing what your did and it wound up being a dirty/fatigued circuit breaker that was in there that prevented overcurrent from blowing the horns. A little contact cleaner and it was back to working like new.

     

    You can also have wire that gets over heated. Once the insulation gets hot enought, the insulation separates from the copper wire and oxygen gets in and the copper oxidezes. Once that happens the wire gets crackely. instead of the individual strands working as a single wire, the copper strands each get oxidized and each strand gets a tarnished skin on them. This causes all kinds of noise when a signal is passed through them. Its also why you should never ever use a guitar cord for a speaker application. The plastic insulation is low temp and low voltage designed for less than one volt. Pass 70+ volts from a speaker jack and the insulation melts away from the copper and lets oxygen in and the cord becomes noisy and microphonic.

    Temp too makes metal expand and contract. Copper and lead expand and contract at two different rates so what once may have been a good solder bond, can become cracked, especially in a speaker cab where the constant vibration is occuring. Thas why they usually use clip on connections to allow for the metal contractions.

    You also have cable connectors that fail over time even though they arent on the road on a daily basis. Oxygen, heat, moisture dust and aging are all factors in failure. I notice more cable failures in my studio during the hot humid summers because of the moisture getting into contacts. Pot sliders and switches too have more issues with humidity than the cold as well.

     

    It can also be the speaker itself. When I used to do equipment repairs for a living I'd find ndozens of speakers that just blow themselves appart through normal use. Speakers are and electro mechanical device thats basically just glued together. The wires between the connector and cone are usually the first things to go. You can also have the surrounds crack, mounting screws loosen and the speaker basket loosen and twist and cause binding.

     

     

    The cables, amps Mixer etc can be easily ruled out by swapping the two sides. If the problem moves you know its not in the cabinet. If it stays, Best thing you can do is open the cab and inspect and clean all electronic connections. Start at the jack and move along towards the crossover and speakers cleaning all connections.  I suspect its just a dirty connection because when a speaker blows it doesnt come back and work properly again. Its likely a connection or a solder joint fault colse eyed inspection should be able to find.    

    Comment


    • R Anderson
      R Anderson commented
      Editing a comment
      Super Contributor -

      I greatly appreciate your incredibly detailed and gracious response.

      Thank You!

  • #3

    You said Mackie Mixer.


    Google "Mackie Ribbon Cable issue"

     

    wala.

    Comment


    • R Anderson
      R Anderson commented
      Editing a comment
      I will check it out. Thank you.
      R


Working...
X