Harmony Central Forums
Announcement Announcement Module
Collapse
No announcement yet.

I got myself a Traynor YBA-1 Tribute

Page Title Module
Move Remove Collapse









X
Conversation Detail Module
Collapse
  • Time
  • Show
Clear All
new posts

  • I got myself a Traynor YBA-1 Tribute

    And it ROCKS.

    So far, I love it, and I haven't really given each setting enough play time yet. The attenuator allows me to run it on 2.5, 5, 10, 20, or 40W power. I like running it on 10W as of now. 40W is FREAKING LOUD. I also like plugging it into the "Lo I" input. I've got additional options for "Hi I", "Hi I+II" and "Lo II" inputs. I've got a lot of playing around to do with this amp.


    Anyhoo, pics, or it's a Squier, right? I'm going to take it one step further and add some sound clips, so you guys can listen to me hacking at guitar (Does anyone know how to post Soundcloud clips directly to HC?).

     

     photo DSC01777.jpg
     photo DSC01789.jpg

     

    Sound clips: https://soundcloud.com/david-m-chau/sets/yba-1-sound-clips

    www.maverickguitar.ca

  • #2

    Very bloody nice!  I bet its loud.  You've got some nice equipment there.  I wish we had traynor down here, I'd love a YCV20WR.

    One MIA Fender Strat, one Gibson Les Paul, one Martin Acoustic, what more do you need?

    http://i1099.photobucket.com/albums/...ps92b32f13.gif

    Comment


    • dmc69
      dmc69 commented
      Editing a comment

      That's a shame, nobody down under carries Traynor?



Working...
X