Harmony Central Forums
Announcement Announcement Module
Collapse
No announcement yet.

Need help with new amp build, blowing fuses.

Page Title Module
Move Remove Collapse









X
Conversation Detail Module
Collapse
  • Time
  • Show
Clear All
new posts

  • Need help with new amp build, blowing fuses.

    \_DSC0459.JPG

     

    I just finished a Fender Champ kit from triodeelectronic, all went well, I made the chasses from .08 alum sign material, drilled the holes, scored the bends .02 deep with my wood blade on my radial arm saw, .005 deep cut at a time then bent with some force by hand, no brake needed, made some stencils for the black face, designed a front ported cab for better bottom...

    But I keep blowing the 1 amp slow blow fuse when I turn off the stand by. The second fuse lasted for a while and the amp sounded great at all volumes, but when I turned it on again to try my Strat and then turned off the standby, a couple of seconds went by then pop the fuse blew. I checked the amp draw,- on Standby it's .22 amp, -Standby off it's 2.24 amps. (for about a second using a 1.5 amp fuse), then I turned it off not to blow another fuse. I am using a larger 15 watt OT. so to also use a 6L6 but I tested it with 2 diferent 6V6'S (JJ) in case the power tube was bad. The tech guy at trio has not got back with me after several days. My speaker tested at 7 ohms, I'm using the 8 ohm socket.

     

    \_DSC0434.JPG

    Attached Files

  • #2

    \_DSC0459.JPG

    Attached Files

    Comment


    • LARRY L
      LARRY L commented
      Editing a comment

      This is odd. I started the thread in the AMP section but after over 120 views, no comments back, is the forum working right? Now here over 20 views, no replies??



Working...
X