Harmony Central Forums
Announcement Announcement Module
Collapse
No announcement yet.

Fender Ultimate Chrous 2x12

Page Title Module
Move Remove Collapse









X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fender Ultimate Chrous 2x12

    I just bought this amp. I got it for $50 dollars because it was broken. I fixed the inputs and it sounds a little better. Im still getting this static sound when i play. Does anyone have an idea what the problem might be?

    Also, when I turn the amp on and off, the amp makes a really loud pop even when the volume is turned all the way down.

  • #2
    I have one, had it since 97', it makes a loud pop when i turn it off too.

    If your static is when you turn the knobs, you have dirty pots, other than that you said it was broke, could be alot of things???
    <div class="signaturecontainer"><font color="magenta">I endorse Laura &amp; Valve Queen tubes, you should too.<img alt="" border="0" title="Thumbs up Phil" src="http://img3.harmony-central.com/acapella/ubb/Phil-Thumbs-Up-Small.gif"></font><img alt="" border="0" title="love" src="http://img3.harmony-central.com/acapella/ubb/love.gif"><img alt="" border="0" title="love" src="http://img3.harmony-central.com/acapella/ubb/love.gif"><img alt="" border="0" title="love" src="http://img3.harmony-central.com/acapella/ubb/love.gif"><img alt="" border="0" title="love" src="http://img3.harmony-central.com/acapella/ubb/love.gif"><img alt="" border="0" title="love" src="http://img3.harmony-central.com/acapella/ubb/love.gif"><br><font size="5"><font color="Red">Marshall, Gibson, Fender, Charvel/Jackson.</font><img alt="" border="0" title="Snacks" src="http://img3.harmony-central.com/acapella/ubb/snacks.gif"></font><br><font size="4"><font color="Blue">&quot;I'm happy to pay my tech $40 bucks to take the Zap for me.&quot;<img alt="" border="0" title="lol" src="http://img3.harmony-central.com/acapella/ubb/icon_lol.gif"></font></font><br>One kick-butt deal with johnpace2 <img alt="" border="0" title="thumbs up" src="http://img3.harmony-central.com/acapella/ubb/thumb.gif"><br><font size="5"><font color="orange">Dave Friedman of RACKSYSTEMS is a genius.<img alt="" border="0" title="idea" src="http://img3.harmony-central.com/acapella/ubb/idea.gif"></font></font><br><font color="DarkOrange"><font color="Magenta">After the Firebird X, i'm quite convinced Henry Juszkiewicz is crazy.</font></font><br><font size="5"><font color="darkorchid">Member of the JMP Hall of Fame.</font></font></div><br>

    Comment


    • #3
      first we thought it was the inputs, but when i put in new inputs, it sounded a little better. when i got it, you could barely hear anything. now its when ever i play on it. i think it might have to do something with the capacitors?????
      help????!!!!!

      Comment


      • #4
        It would probably be cheaper in the long run to get a small tube amp, than to put any $$$ into this one IMHO.oke:oke:oke:oke:oke:oke:

        I sometimes run an amp modeler thru mine but i only use the clean channel, i also have 6 other amps, so for me it doesn't matter.

        If this is your only amp i'd say shop around you could do better, they stopped making the UC along time ago.
        <div class="signaturecontainer"><font color="magenta">I endorse Laura &amp; Valve Queen tubes, you should too.<img alt="" border="0" title="Thumbs up Phil" src="http://img3.harmony-central.com/acapella/ubb/Phil-Thumbs-Up-Small.gif"></font><img alt="" border="0" title="love" src="http://img3.harmony-central.com/acapella/ubb/love.gif"><img alt="" border="0" title="love" src="http://img3.harmony-central.com/acapella/ubb/love.gif"><img alt="" border="0" title="love" src="http://img3.harmony-central.com/acapella/ubb/love.gif"><img alt="" border="0" title="love" src="http://img3.harmony-central.com/acapella/ubb/love.gif"><img alt="" border="0" title="love" src="http://img3.harmony-central.com/acapella/ubb/love.gif"><br><font size="5"><font color="Red">Marshall, Gibson, Fender, Charvel/Jackson.</font><img alt="" border="0" title="Snacks" src="http://img3.harmony-central.com/acapella/ubb/snacks.gif"></font><br><font size="4"><font color="Blue">&quot;I'm happy to pay my tech $40 bucks to take the Zap for me.&quot;<img alt="" border="0" title="lol" src="http://img3.harmony-central.com/acapella/ubb/icon_lol.gif"></font></font><br>One kick-butt deal with johnpace2 <img alt="" border="0" title="thumbs up" src="http://img3.harmony-central.com/acapella/ubb/thumb.gif"><br><font size="5"><font color="orange">Dave Friedman of RACKSYSTEMS is a genius.<img alt="" border="0" title="idea" src="http://img3.harmony-central.com/acapella/ubb/idea.gif"></font></font><br><font color="DarkOrange"><font color="Magenta">After the Firebird X, i'm quite convinced Henry Juszkiewicz is crazy.</font></font><br><font size="5"><font color="darkorchid">Member of the JMP Hall of Fame.</font></font></div><br>

        Comment


        • #5
          yeah, i just picked it up for fun

          i have other amps, im just trying to fix it and make profit

          Comment


          • #6
            What do you mean changed the inputs?
            <div class="signaturecontainer"><font size="1"><b><br />
            Great transactions with</b>: hivedestruction, TheBumRush, Invader.CC, gchatred, pfindeis, aporcelainsky</font><font size="1">, tantamo, mueller, Tone Meister, vidiot72, angelhair0 (x2), Bleedback, Insubordination, ibanez_dude, 6StrngStrangler, goodhonk, andy3033<br />
            <br />
            <a href="http://acapella.harmony-central.com/showthread.php?2910935-FS-Zvex-Box-of-Rock-and-General-Guitar-Gadgets-PT80-delay&amp;p=45908648#post45908648" target="_blank"><font color="red"><b><font size="3">Can o' Spam</font></b></font></a><br />
            <font color="black">GGG PT80</font><br />
            <br />
            </font></div>

            Comment


            • #7
              I took out the actual inputs because they were broken
              Then I put new ones in and it sounds a ton better

              Comment


              • #8
                What do you mean changed the inputs?



                I think he means he replace the input "jacks".
                <div class="signaturecontainer">Marshall JCM800 2204<br />
                Marshall Lead 100 Mosfet<br />
                Laney AOR ProTube 50</div>

                Comment


                • #9
                  I took out the actual inputs because they were broken
                  Then I put new ones in and it sounds a ton better


                  Does the static change at all when you turn any of the knobs. Just as a routine maintainance, spray some contact cleaner into the openings on the backs of all the pots and then turn them back and forth a few times and then spray some into the effects loop jacks and insert and remove a cable a few times. May not be your problem but, you should eliminate all possible simple fixes first.
                  <div class="signaturecontainer">Marshall JCM800 2204<br />
                  Marshall Lead 100 Mosfet<br />
                  Laney AOR ProTube 50</div>

                  Comment


                  • #10
                    I hear static all the time, its pretty much if i play anything. When I'm on the clean channel, its loudest in the bass, quietest when trebles all the way. So, I'm just really confused

                    Comment


                    • #11
                      The pop is the reverb tank I think. My bro has a princeton chorus from the same era and it does the same thing.

                      Comment



                      Working...
                      X