Harmony Central Forums
Announcement Announcement Module
Collapse
No announcement yet.

My MXR EQ failed on me today. Help me diagnose the problem.

Page Title Module
Move Remove Collapse









X
Conversation Detail Module
Collapse
  • Time
  • Show
Clear All
new posts

  • My MXR EQ failed on me today. Help me diagnose the problem.

    My 10 band MXR EQ started making a huge noise/hum sound with pops that just overrules the amp sound since yesterday. It's the first thing in the FX loop and then my Decimator comes right after it. But it can't filter the noise without touching the amp tone.

    It's not my FX loop as my Decimator works flawlessly without the EQ in there. It's terrible. Could it be the powersource or something, or a dirty jack. Or has anyone had this with a pedal and it turned out to be screwed inside?

  • #2
    does it happen when the unit is turned off (in bypass mode)?
    BRO CLUB Member: BROSLINGER
    Proudly uses: STOMP UNDER FOOT pedals.

    Comment


    • #3
      Yeah it does...

      Comment


      • #4
        Yeah it does...


        this is probably a good thing.

        could be bad switch, bad jack, IDK.
        BRO CLUB Member: BROSLINGER
        Proudly uses: STOMP UNDER FOOT pedals.

        Comment


        • #5
          mine does this too, when it does it when it's off 2 of the middle sliders light up
          late 70's gibson sg custom
          2006 gibson sg standard
          1985 gibson explorer
          mesa mark III blue
          peavey bravo 112
          red bear mk60

          Comment


          • #6
            one of mine did this but it was when I accidentally plugged in a speaker signal into it

            now it makes a loud farty sounding mess and the two outer led's flash all the time... I need to send it back but I'm lazy... and have another one.
            Guitars
            Tokai LS150 - Sheptone Bryan Kahaek Signature pickups - Mystic Dream MM JP6 - G&L Comanche

            Amps - Cabs
            Splawn "MUFASA" Nitro - Mako MAK4 Preamp - Jet City 100H w/JJ KT66's, 22H & Pico Valve - Whitebox Engineering 2x12, PortCity OS212 - Splawn 4X12

            Kemper Profiling Amp - u mad?

            Visit my music page

            Watch my amp demo videos on Youtube

            Member of the Jet Setters

            Comment



            Working...
            X