Harmony Central Forums
Announcement Announcement Module
Collapse
No announcement yet.

Peavey Ultra Plus = Problems

Page Title Module
Move Remove Collapse









X
Conversation Detail Module
Collapse
  • Time
  • Show
Clear All
new posts

  • Peavey Ultra Plus = Problems

    Got it 2 weeks ago...a week and a half of that time it was getting fixed because it made a loud pop, and died...got it back yesterday it was fine. Then, I played it today, did the same thing BUT now it turns on and no sound. My question is, should I have them fix it again for free, or get something else?

  • #2
    Tube ?
    What was the last problem ?
    A bad tube will blow the fuse .
    " "Best toan in teh land" - champion

    Good Buyers/Sellers :Mikenothing , SirKonks,Dimebag11 x2,Dropped_2_c,Boris the Blade,thefyn,MrSandman,Gabe15,GuidanceOfSin,shane1 59 X2,Mparsons,rabott13,warplangrey,iamthearm, SkyHighRocks,RobotBodiesBFF,Tu Be x2,IanDOL,Fridgit,Jim Ansell ,GutterMouth,LionHeaRT07 ,Zao X2,m3at,Bluesman001,Khoifish321,thinkpad20,vangkm, juice,phatgirl,Trembulant,knope , Knucklefux, pfapin,rareguitar,donsimon76, again with this, Jerry Dyer, eagertokill,rugbyguitargod

    Comment


    • #3
      Tube ?
      What was the last problem ?


      That's the best part, the tech didn't tell them what was wrong! He doesn't work for the store, he's just some dude they hire to do their amp stuff. I'm pretty sure it was a fuse or a tube, my old blue voodoo did the same thing (turned on, no sound) and it was a couple caps, but it's a nightmare so far though

      Comment


      • #4
        Check the fuses , I think the up has a fuse inside the amp as well , I can't recall .
        " "Best toan in teh land" - champion

        Good Buyers/Sellers :Mikenothing , SirKonks,Dimebag11 x2,Dropped_2_c,Boris the Blade,thefyn,MrSandman,Gabe15,GuidanceOfSin,shane1 59 X2,Mparsons,rabott13,warplangrey,iamthearm, SkyHighRocks,RobotBodiesBFF,Tu Be x2,IanDOL,Fridgit,Jim Ansell ,GutterMouth,LionHeaRT07 ,Zao X2,m3at,Bluesman001,Khoifish321,thinkpad20,vangkm, juice,phatgirl,Trembulant,knope , Knucklefux, pfapin,rareguitar,donsimon76, again with this, Jerry Dyer, eagertokill,rugbyguitargod

        Comment


        • #5
          Ps , I'd call the store and get the guys name and number and call him up to see what he replaced .
          It wouldn't surprise me if he replaced the main and said it was good to go , there are a lot of hacks out there .
          Sounds like the ot fuse this time.
          " "Best toan in teh land" - champion

          Good Buyers/Sellers :Mikenothing , SirKonks,Dimebag11 x2,Dropped_2_c,Boris the Blade,thefyn,MrSandman,Gabe15,GuidanceOfSin,shane1 59 X2,Mparsons,rabott13,warplangrey,iamthearm, SkyHighRocks,RobotBodiesBFF,Tu Be x2,IanDOL,Fridgit,Jim Ansell ,GutterMouth,LionHeaRT07 ,Zao X2,m3at,Bluesman001,Khoifish321,thinkpad20,vangkm, juice,phatgirl,Trembulant,knope , Knucklefux, pfapin,rareguitar,donsimon76, again with this, Jerry Dyer, eagertokill,rugbyguitargod

          Comment


          • #6
            Ps , I'd call the store and get the guys name and number and call him up to see what he replaced .


            Ya I'm going there tomorrow after work and I'm going to tell them to tell the tech to call me and tell me what was wrong....but I dunno if it happens after this, I'm gonna

            Comment


            • #7
              Damn, sorry to hear that. I hope you get it worked out. I've owned and gigged with 4 different Ultra amps and they were all bullet proof.

              Cheap, versatile workhorses in my experience.
              "You won't like me when I'm angry because I back up my rage with facts and documented sources" ~ The Credible Hulk

              Comment


              • #8
                I'm pretty sure the dude prob replaced one fuse, not all, and one of the power tubes is bad....my guess anyway.

                Comment


                • #9
                  Got it 2 weeks ago...a week and a half of that time it was getting fixed because it made a loud pop, and died...got it back yesterday it was fine. Then, I played it today, did the same thing BUT now it turns on and no sound. My question is, should I have them fix it again for free, or get something else?


                  mine blew a fuse at my first gig.

                  Its probably whats happening.
                  Guitars:Gibson Les Paul Standard FadedFender Roadworn '72 Deluxe TelecasterKramer StrikerAmplification:Titan Custom RetrofitRandall R412CSOfficial member of the Ninja Lows club

                  Comment


                  • #10
                    Make sure your next bill gets discounted by however much you already paid.
                    That's a good amp, I wouldn't off it just because the "tech" wasn't paying attention.
                    GIBSON | PRS | SQUIER | EPIPHONE | BLACKSTAR | PEAVEY | MARSHALL | JET CITY | CRATE (ZOMG!!!)

                    The Band

                    Good Transactions







                    Originally Posted by Ovid9


                    I thought it was more the fact your walls were covered in pictures of skinny guys with long hair.

                    How did you fap in a room like that?



                    Proud owner of the first NAD of the new HC

                    Comment


                    • #11
                      Ya I'm not even paying either, musicgoround is cause they screwed it up, so I'm probably gonna tell him to retube it with some Winged C's.

                      Comment



                      Working...
                      X