Harmony Central Forums
Announcement Announcement Module
Collapse
No announcement yet.

Help - no sound coming out from my Splawn Quickrod and Marshall Jubilee

Page Title Module
Move Remove Collapse









X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help - no sound coming out from my Splawn Quickrod and Marshall Jubilee

    My Splawn Quickrod and Marshall Jubilee have both suddenly stopped working. I have turned them on, both of them looks fine, all tubes lighted up, just no sound coming out, and dead slient. You guys have any ideas what might caused the problem?

    Thanks
    Amp heads:
    Diezel Einstein 100
    Custom Audio Amplifiers OD50
    VHT Ultra Lead
    VHT Sig X
    Elmwood Modena 60
    Splawn Quickrod
    Engl Blackmore
    Mesa Stilletto Deuce II
    Mesa Dual Rectifier Blackface
    Marshall Jubilee 2555 SL
    Marhsall JCM800KK
    Soldano Avenger 100
    Orange Dark Terror

    Racks
    Marshall JMP-1
    Mesa Quad preamp
    VHT 2/90/2

  • #2
    Have you tried different cabs?
    Guitars:Gibson Les Paul Standard FadedFender Roadworn '72 Deluxe TelecasterKramer StrikerAmplification:Titan Custom RetrofitRandall R412CSOfficial member of the Ninja Lows club

    Comment


    • #3
      Have you tried different speaker cables, instrument cables, cabs and guitars?

      Comment


      • #4
        Hit them with a hammer, if that don't work get a bigger hammer.
        Proud Member of the Jet Setters (Jet City Lounge)

        Comment


        • #5
          yep tried everything. Should the the amps themsleves. Coz I tried my other amps with the same cables/cab etc. and worked fine.
          Amp heads:
          Diezel Einstein 100
          Custom Audio Amplifiers OD50
          VHT Ultra Lead
          VHT Sig X
          Elmwood Modena 60
          Splawn Quickrod
          Engl Blackmore
          Mesa Stilletto Deuce II
          Mesa Dual Rectifier Blackface
          Marshall Jubilee 2555 SL
          Marhsall JCM800KK
          Soldano Avenger 100
          Orange Dark Terror

          Racks
          Marshall JMP-1
          Mesa Quad preamp
          VHT 2/90/2

          Comment


          • #6
            yep tried everything. Should the the amps themsleves. Coz I tried my other amps with the same cables/cab etc. and worked fine.


            That is weird. Is it possible that both amps were in use at the same time during some event that might have lead to blown fuses?

            Comment


            • #7
              erm...I haven't turned the Jubilee on for about two months and it was working fine before that. The Quickrod I did use it frequently without any problems. But the amps can still be on with a blown fuse?
              Amp heads:
              Diezel Einstein 100
              Custom Audio Amplifiers OD50
              VHT Ultra Lead
              VHT Sig X
              Elmwood Modena 60
              Splawn Quickrod
              Engl Blackmore
              Mesa Stilletto Deuce II
              Mesa Dual Rectifier Blackface
              Marshall Jubilee 2555 SL
              Marhsall JCM800KK
              Soldano Avenger 100
              Orange Dark Terror

              Racks
              Marshall JMP-1
              Mesa Quad preamp
              VHT 2/90/2

              Comment


              • #8
                If you are using the loop in the qr a cable might not be in the jack all the way.....

                Comment


                • #9
                  Hit them with a hammer, if that don't work get a bigger hammer.


                  If that fails send them to me.

                  Comment


                  • #10
                    erm...nah not using the loop at all, I have bypassed it.
                    Amp heads:
                    Diezel Einstein 100
                    Custom Audio Amplifiers OD50
                    VHT Ultra Lead
                    VHT Sig X
                    Elmwood Modena 60
                    Splawn Quickrod
                    Engl Blackmore
                    Mesa Stilletto Deuce II
                    Mesa Dual Rectifier Blackface
                    Marshall Jubilee 2555 SL
                    Marhsall JCM800KK
                    Soldano Avenger 100
                    Orange Dark Terror

                    Racks
                    Marshall JMP-1
                    Mesa Quad preamp
                    VHT 2/90/2

                    Comment


                    • #11
                      The qr will still turn on with a blown ht fuse.
                      " "Best toan in teh land" - champion

                      Good Buyers/Sellers :Mikenothing , SirKonks,Dimebag11 x2,Dropped_2_c,Boris the Blade,thefyn,MrSandman,Gabe15,GuidanceOfSin,shane1 59 X2,Mparsons,rabott13,warplangrey,iamthearm, SkyHighRocks,RobotBodiesBFF,Tu Be x2,IanDOL,Fridgit,Jim Ansell ,GutterMouth,LionHeaRT07 ,Zao X2,m3at,Bluesman001,Khoifish321,thinkpad20,vangkm, juice,phatgirl,Trembulant,knope , Knucklefux, pfapin,rareguitar,donsimon76, again with this, Jerry Dyer, eagertokill,rugbyguitargod

                      Comment


                      • #12
                        The qr will still turn on with a blown ht fuse.


                        erm..I have checked it too, it "looks" fine to me, I can still see that wire inside the fuse.
                        Amp heads:
                        Diezel Einstein 100
                        Custom Audio Amplifiers OD50
                        VHT Ultra Lead
                        VHT Sig X
                        Elmwood Modena 60
                        Splawn Quickrod
                        Engl Blackmore
                        Mesa Stilletto Deuce II
                        Mesa Dual Rectifier Blackface
                        Marshall Jubilee 2555 SL
                        Marhsall JCM800KK
                        Soldano Avenger 100
                        Orange Dark Terror

                        Racks
                        Marshall JMP-1
                        Mesa Quad preamp
                        VHT 2/90/2

                        Comment


                        • #13
                          You need to check it with a meter. Sometimes they can look fine and still be bad.
                          " "Best toan in teh land" - champion

                          Good Buyers/Sellers :Mikenothing , SirKonks,Dimebag11 x2,Dropped_2_c,Boris the Blade,thefyn,MrSandman,Gabe15,GuidanceOfSin,shane1 59 X2,Mparsons,rabott13,warplangrey,iamthearm, SkyHighRocks,RobotBodiesBFF,Tu Be x2,IanDOL,Fridgit,Jim Ansell ,GutterMouth,LionHeaRT07 ,Zao X2,m3at,Bluesman001,Khoifish321,thinkpad20,vangkm, juice,phatgirl,Trembulant,knope , Knucklefux, pfapin,rareguitar,donsimon76, again with this, Jerry Dyer, eagertokill,rugbyguitargod

                          Comment


                          • #14
                            hmmmm, were you using both of these amps with the same cabinet when they were both working???? not at the same time, but using the same cabinet????? you might wanna get out a multimeter and read the impedence of the cabinet, you may have a problem there that you did not know about.
                            Fiddles: Gibson Les Paul Classic
                            Warmoth homebuilt Strat
                            Xaviere XV-550

                            Amps: Splawn Quick Rod and matching 2x12
                            Laney VC-30112


                            good dealings with/trade references: MRAAJR, SMASHINGTIME, STRATOSLACKER, MASTERBURRFOOT, BLUPLIRST

                            Comment


                            • #15
                              Have you had your power tubes checked to make sure one or two have not blown up? Power tubes can actually light up but still be bad and have low plate voltage. A bad power tube will definitely break the output circuit.
                              "I told my brother, don't baby the thing, hit it hard with your f#&king pick"
                              Malcolm Young

                              Gretsch Malcolm Young Signature 2010
                              Gibson Les Paul Custom 1979
                              Fender FSR Butterscotch BG Tele 2010
                              Marshall JMP Master Vol.(1978) w/Marshall 4x12
                              Marshall JCM900 MkIII (1990) w/Marshall 4x12
                              Radial:BigShot EFx True Bypass Switch
                              Wampler:Plexi Drive(v1)
                              Barber Direct Drive(v3)
                              Boss:TU-3 Tuner
                              VS:Route 808(v2)
                              VS:Liquid Chorus(v2)
                              Morley:A/B Amp Switch

                              Comment



                              Working...
                              X