Announcement
Collapse
No announcement yet.

iphone 3g need 4.3.1

Collapse



X
  • Time
  • Show
Clear All
new posts

  • iphone 3g need 4.3.1

    i need firmware of iphone 3g 4.3.1 of higher any one can help me

  • #2
    Did you try Apple corp? Or did you jailbreak the phone in violation of your ELUA.

    Comment













    Working...
    X